icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.kingprn.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

超级时时彩 www.823613.com-彩钢印花板-| www.4321.pro-彩票序列号-| www.019973.com-彩票533-| www.456438.com-七k彩票网十分彩| www.626884.com-信彩是不是黑网站| www.qv37.com-三分时时彩如何破解| www.105395.com-中国哪里卖无嘴好彩| www.207055.com-至尊快三开奖结果| www.th93.com-全天安徽快三计划网| www.70380.com-奔驰彩票登录入口| www.880872.com-9188彩票网骗局| www.869208.com-巨丰彩票网站| www.996466.com-足彩佬牛新浪慱客| www.01dc.com-美丽的彩虹教案| www.0011.ren-七星体彩几点开奖| www.947366.com-彩票诈骗怎么处理| 凤凰彩票www.55228e.com| www.255063.com-彩票预测专家双色球| www.504563.com-踩台和彩排是一样吗| www.11003.cc-彩票驿站大发快| www.1849.org-彩票八-| www.67009.cc-福彩销售点投诉电话| www.699998.cc-瑞典2分彩计划| www.857664.com-彩之源这个是真的么| 99福彩www.379969.com| www.372217.com-黄鹤楼大彩隐藏抽法| www.512272.com-简单清新彩铅画| www.608699.com-微信彩票网址| www.708456.com-杭州体育彩票网址| www.826508.com-苏宁彩票ap-| 金掌柜www.83993f.com| www.702056.com-竞彩推荐app| www.791995.com-附近彩票站有多远| www.872090.com-贵州省体彩兑奖地址| www.943649.com-连中彩票官网| www.990400.com-彩票的秘密-| www.bg81.com-彩票计划师的大揭秘| www.3569.net-双色球中彩网讨论区| www.8430.net-彩票中奖公布| www.858949.com-彩票查-| www.947922.com-体育彩票的规则介绍| www.52na.com-江苏结婚不给彩礼| www.3736.biz-今晚七星彩什么上将| www.8887.org-福彩十二生肖玩法| www.583159.com-全彩色漫画-| www.769500.com-盈彩娱乐是骗局吗| www.905456.com-体彩任九推荐| 手机购彩www.715699.com| www.11ql.com-西安天彩粮骗局休假| www.6873.biz-爱彩人彩票网下载| www.ir58.com-乐乐彩票网是真的吗| www.188792.com-vip彩票网站地址| www.581090.com-广西快三淘宝| www.2480.me-e球彩有多少奖金| www.9177.cc-新加坡大彩奖金分类| www.55190.com-腾讯分分彩开奖快| www.009064.com-瑞彩祥云注册邀请码| www.266733.com-河北快三走杀号| www.422518.com-乐乐彩票赌博案| www.552268.com-好盈彩票骗局揭秘| www.671586.com-重庆时时彩追杀吗| www.870493.com-152彩票邀请码| www.082579.com-118彩票怎么回事| www.233665.com-彩乐汇是真的吗| www.339415.com-东莞市彩票支票| www.442508.com-足彩篮彩分析软件| www.87833.com-彩票如何杀龙| www.566507.com-济南和彩日本料理| www.234822.com-福彩211路遗漏| www.171746.com-河南快三连线走势图| www.44141.com-彩球官网aap| www.000568.com-时时彩慢慢回血经验| www.072044.com-快频彩票软件| www.203698.com-体彩速查表-| www.317903.com-广东十分彩开奖结果| www.434004.com-关彩唏种子-| www.522748.com-时时彩豹子出号技巧| www.362008.com-万彩吧官方下载| www.098952.com-ig传统彩怎么玩| www.54206.com-加微信送体验彩金| www.uc88.com-高频彩票叫停吗| www.890368.com-手机彩票登录| www.39196.cc-6188彩票合法不| www.078528.com-安徽滁州体育彩票| www.560289.com-登录全民彩票官网| www.645846.com-彩票站有重庆时时彩| www.738632.com-彩网总站-| www.809086.com-好彩客老版-| www.881624.com-微信彩票计划群和买| www.051004.com-快三有赚钱的么| www.193768.com-吉林省体彩兑奖电话| www.3988.bid-上海男方给女方彩礼| www.338246.com-大家乐彩票是真的吗| www.172197.com-江西快三彩票网页| www.327713.com-快三试机号-| www.502618.com-一号彩票代理人有吗| www.599302.com-彩票天机图-| www.819654.com-合买彩票的好处| www.938866.com-金利彩票是不是骗局| 68彩票www.68689h.com| www.uh98.com-贵州快三三不同全选| www.32vv.com-掌优彩票黑平台| www.8443.cn-亚博体彩是诈骗吗| www.105383.com-江苏体彩e球胜负平| www.66952.cc-广东福彩主任是谁| www.132481.com-世界杯足彩买比分| www.204765.com-江西快三投注道风云| www.269331.com-彩票站打错号码案例| www.883111.com-多彩投众筹平台官网| www.rq26.com-五分钟彩快开彩票| www.879937.com-内蒙古快三热点| www.997791.com-赌一分快三输了6万| www.el91.com-快三开挂器-| www.6is.com-你存我送彩票活动| www.142.tv-夸人好看的彩虹屁| www.4je.cc-内蒙古快三预测定牛| www.61nq.com-体彩七星开奖查询| www.1292.cn-彩票查询大乐透开奖| www.7158.net-博彩公司取名字| www.761544.com-我要体彩的开奖号码| www.462454.com-彩生活物业工资待遇| www.845252.com-福彩082期字谜图| www.927654.com-体育彩票手机版| www.977997.com-彩钢皮墙-| www.cai2226.com河北快三套选玩法| www.bl43.com-购彩大厅360| www.66an.com-中国体育彩票洗钱| www.ap90.com-遵义市福彩-| www.wa20.com-福彩快三讨论群| www.888581.com-大发快三买大出小| www.978740.com-500w彩票网网址| www.cai9233.com兰州快三一天多少期| www.pr29.com-彩票快三助手下载| www.729750.com-福彩模拟选号3d| www.936287.cc-凤凰彩票网计划| www.833.live-今日体彩的开奖号码| www.025524.com-大发彩票骗局| www.767589.com-福彩3d定位-| www.690553.com-可以购彩的app| www.789364.com-彩妆店图片-| www.873810.com-彩31网站-| www.964033.com-欢迎光临500彩票| www.cai7099.com贵州快三形态走势图| www.088878.cc-买快三的官方平台| www.089001.com-最新彩票33安卓版| www.139039.com-567彩官方网址| www.036014.com-双色球彩票开奖| www.31nx.com-抖音彩虹鸭-| www.32fu.com-彩票美国28-| www.45oa.com-彩票店开到几点| www.322819.com-凤凰网彩票平台| www.425448.com-重庆时时彩遗漏数据| www.582699.com-彩色装饰画图片简单| www.686187.com-彩票挂机助手| www.840619.com-广西体育彩票骗局| www.919613.com-靠谱的彩票平台程序| www.983407.com-创名彩票-| www.095068.com-好彩论坛高手| www.308544.com-逸彩快三是真的假的| www.448110.com-河南7星彩开奖查询| www.588070.com-竞彩比分最多串几场| www.790038.com-西宁体彩11选5| www.908222.com-快乐彩票手机版下载| 彩票驿站www.621481.com|